Download Evasion 1.5.2 Tool for iOS 6.1.2


For those of you who still do not know, Evasion is the famous jailbreak tool, which allows users to perform untethered jailbreak on their iPhone, iPad or iPod Touch running on iOS 6 or later. With the first version of Evasion released, users encountered certain bugs and issues such as Cydia package issue and long booting problem. In this respect, the Evad3rs team upgraded the jailbreak tool in order to fix all those problems.

Download Evasion 1.5.2 Update

Along with each iOS version released by Apple, Evad3rs also upgraded their tool in order to make jailbreak possible. Now, Evasion is updated once again, and it has reached version 1.5.2. The new version does not bring any other bug fixes or changes as some of you might expect. Its sole purpose is to feature some new language localizations. This means that it now has support to include localizations for three other languages such as French, German and Chinese. These three languages are the native languages of the Evad3rs team members.

As you know, untethered jailbreak using Evasion is possible only for iOS 6.x running devices. When the new firmware will be released and namely the iOS 6.1.3, jailbreak using the Evad3rs’ jailbreak tool will no longer be possible. The new update will patch all exploits used by Evasion in order to assure a jailbreak status for any iDevice.

For those of you who already performed untethered iOS 6 jailbreak on their devices and you do not want to include the extra package with these three languages, then there is no need for you to start jailbreak once again. On the other hand, if you enjoy keeping in touch with the latest tools concerning jailbreaking, then you are free to download Evasion 1.5.2 tool in order to start untethered jailbreak on your iPhone, iPad or iPod Touch. Feel free to check our iOS 6 untethered jailbreak tutorial using Evasion.

Direct links for Evasion 1.5.2

Download Evasion 1.5.2 for Windows

Download Evasion 1.5.2 for Mac

Download Evasion 1.5.2 for Linux

DISCUSS4

4 Comments

  1. SKATEskum
    SKATEskum October 26, 2013 at 4:35 pm

    I’ve a mature first generation ipod device touch with iOS version 5 onto it and also the wi-fi compatability is spotty at the best. Do more recent decades from the touch or more recent versions of iOS boost the wi-fi compatability quality? Thanks!

  2. ScRSC
    ScRSC October 27, 2013 at 3:14 pm

    I have attempted to set up it with the website where one can pick either the ios version or google play for android, it creates that it is installed however i cant think it is on my cell phone, not in downloads or anywhere, plus i have attempted discovering it on htc likes but no searches for this not found.

  3. Jesse
    Jesse November 2, 2013 at 2:05 am

    I’ve an apple iphone 3rd generation and nowadays i cant have any applications or games. The ios version is 4.2.1 and also the minimum needed is 4.3 however i cant update since the new ios 4.2.1 may be the last update. I’d favour applications or games NOT CRACKED the wi-fi compatability nick or antennae broke and so i cant install everything from cydia.

  4. krow147
    krow147 November 2, 2013 at 3:59 am

    It’s iOS version 6..1 and that i will pay some cash if required. It should be FACTORY UNLOCKED though. Jailbreaking it also it setting it up unlocked will just allow it to be slow and may ‘t be up-to-date. It’s a Sprint company, and i’m a T Mobile company, I simply bought this phone from my pal while he got the brand new apple iphone 5.

Leave a Reply

FILED UNDER